Olá!

Hoje fui atualizar o meu WordPress 2.6.1 para 2.6.3 e não deu muito certo. Depois de fazer upload dos arquivos da versão nova, acessei o wp-admin e fiz o login com o usuário administrador e tomei a mensagem ““Você não tem permissão para acessar essa página” na minha face.

Mas antes fiz um backup básico de todo o diretório do WordPress e da base de dados que ele usa. Sempre faça backup!

Oras bolas, no site a promessa é essa:

Atualizando de qualquer versão do WordPress para a 2.6:

Antes de atualizar qualquer coisa, tenha certeza de ter feito uma cópia de segurança de todos os arquivos que você modificou como o index.php.

  1. Apague seus arquivos antigos do WordPress, salvando os que você modificou.
  2. Faça o upload dos novos arquivos.
  3. Acesse a página /wp-admin/upgrade.php com seu navegador.

Você queria mais? É só isso!

Pra corrigir fiz o seguinte:

  1. Alterei as permissões do arquivo wp-config.php para 755;
  2. Depois abri esse arquivo e altere as linhas abaixo colocando meu frase única.
    define(‘AUTH_KEY’, ‘robertojundi_1’); // Change this to a unique phrase.
    define(‘SECURE_AUTH_KEY’, ‘robertojundi_2’); // Change this to a unique phrase.
    define(‘LOGGED_IN_KEY’, ‘robertojundi_3’); // Change this to a unique phrase.
  3. Após isso acessei a URL da administração e não é que fazendo sóóó isso funcionou?!

Dá próxima vou arriscar usar o plugin InstantUpgrade.

Até mais

Share


Um comentário

  1. #
    Fernando Scherrer
    novembro 2nd, 2008 at 18:19

    Haw!

      A versão em inglês do documento parece um pouco melhor:

        http://codex.wordpress.org/Upgrading_WordPress

      Veja a nota do parágrafo "Also take care to preserve the content of the wp-config.php file (…)", mais especificamente "(…) see Extended upgrade instructions (…)".

    Falowz!?

    Responda a esse comentário

Deixe um comentário